Skip to content
Advertisement

‘react-router-dom’ does not contain an export named ‘useHistory’

Im trying to import useHistory from react-router-dom but it keeps giving me the error ‘react-router-dom’ does not contain an export named ‘useHistory’.

React-router-dom’s version is 4.3.1 and i’ve tried updating (in case there was an updated version) but every time i do npm install react-router-dom it always just installs 4.3.1 It updated react-router from 4.3.1 to 5.2.0 just fine so i don’t know why react-router-dom doesn’t update (if there is an updated version).

If anyone knows another way to import useHistory or make a back button that goes to the previous URL from anywhere I’d love to know.

Advertisement

Answer

You can update react-router-dom package by manually changing the version in package.json to 5.2.0

or

install the specific version by using the below command

npm i react-router-dom@5.2.0

or the latest version like

npm i react-router-dom@latest
Advertisement