Skip to content
Advertisement

How to refactor and optimize function

I have two points in x,y,z format. If p1.x < p2.x I want my variable directionX = 1, otherwise directionX = -1.

“1” means later to increase p1.x in distance calculation until it becomes 15 (for example below). It’s find unknow point task where I have only distance and starting point coordinates. Basically I did this task. But I can’t refactor and orginize my code in better way =(

At first I want to find in what direction later to change x,y,z. By changing x,y,z I see how distance increases or decreases. This is my logic to find unknow point.

But I found difficult to refactor my “findDirection” function. It is huge and makes same work 3 times for x, y , z.

JavaScript

How to make like this

JavaScript

Advertisement

Answer

I would extract the calculation for each coordinate into a separate function. I pass the coordinate variable to it which chooses the corresponding key from the object. Also you don’t need to mutate the p1 object, so I create a copy of it, but increment the required coordinate by 1. The resulting distance can also be an object rather than three separate variables.

JavaScript
User contributions licensed under: CC BY-SA
1 People found this is helpful
Advertisement